Re: HoustonTracker 2 (TI-82/83/83+/84+)

Hi 4ormal,

Thanks for your interest in HT2! As far as I know it's not possible to transfer stuff from PC via the soundcard, as there is no software which supports that. The best option would be to get a SilverLink (TI GraphLink USB) cable - despite what TI says, it works fine with the 82 (using TiLP for the transfer). With a bit of fiddeling, you might also get the (much cheaper) GrayLink USB to work.

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Thanks for the reply Utz smile

Is there anything special I need to install additionally? Do I need to upgrade the firmware ROM to doors, mirage or any of the other custom OS's to get HT2 working? I checked and I'm currently running a stock ROM version 16.0. Also does the TI Silverlink work both ways? (As in being able to backup my save data to my computer) Or can I only receive data to the ti82 with the silverlink?

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Are there any plans available to make a DIY "graylink" cable?  It seems like it would be fairly straight forward.


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Yes, you can use the SilverLink both ways.

In order to install HT2, you'll need to install the CrASH shell first. Detailed instructions and a link for obtaining CrASH can be found in the install section of the manual.

There was indeed some talk about making a DIY GrayLink cable, but so far the plans haven't progressed very far. Btw you might try to squeeze a sample from here, though there's no guarantee those will actually work.

Re: HoustonTracker 2 (TI-82/83/83+/84+)

I must admit, i'm obsessed with this thread. I come back lurking daily to see if there's any update. Some question. I want to share my Houston Tracker chiptune with the web. Is there any place to post the track where i can find most of the houston tracker composers? What tag should i use on soundcloud? Will there be an option to extract a single song from the backup file as you can do with Lsdj using the "lsdj manager"?

Thank you!


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Hehe, sorry for the current lack of updates smile Rest assured that stuff is happening behind the scenes. Most likely version 2.1 will be ready in a couple of weeks.

There isn't really any central spot for HT composers afaik. A number of HT users are hanging out on chipmusic.org, but it appears there are also quite a few who are not connected to the chip or calculator scene.

About soundcloud tagging, I dunno... I always thought it's best to use a range of different tags. "calculator" seems to be the one people mostly use right now. What's your soundcloud, btw?

i'm working on a "lsdj manager" type utility, but it hasn't progressed very far. I'll put out a public beta soon-ish, though.

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Happy to hear that the project is still growing!
Here's my soundcloud, nothing too serious: https://soundcloud.com/damn-dull-giako/tracks
I'll post my first "calculator track" when it's ready.
Keep up the good work!

33 (edited by gotoandplay 2016-01-17 15:51:56)

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Im having problems getting the crash shell onto my ti-82 before i start with putting ht2 on it.

It is to do with TILP not recognising my device to be able to send files over. When I try and get TILP to scan to find my TI-82 (using silverlink cable), it times out with the 'done!' message after 20 seconds of not finding anything.

Any ideas?

It might be because I got an error when I installed TILP - it could not install the file libticables2-6.dll . I had to manually find that dll elsewhere on the interenet, add it into the TILP directory for TILP to want to run.

Tried reinstalling TILP and it comes up with the same error with the dll, so if it is that, then I'm not sure where to go from there.

Re: HoustonTracker 2 (TI-82/83/83+/84+)

have you tried to send the files with the official TI program?

Re: HoustonTracker 2 (TI-82/83/83+/84+)

I have tried, but TI Connect does not support TI 82 calculators.


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Damn, I seem to be getting more problem reports about TiLP than the actual HT2 lately hmm

Ok, let's see about this one. You definately need that .dll installed, wonder why it won't let you. You probably need to be admin to install it (and the other libti* dlls), but I guess you've tried that already?

As far as the scanning goes, just don't scan, I think it doesn't really work with TI82 anyway. Just set the right combination in the "change device" popup or via command line.

As a last resort, you could try an older version of TiLP (or newer if you don't have the latest 1.17). Make sure you uninstall everything that came with TI Connect (especially the USB drivers), as TiLP can't coexist with an existing TI Connect install without some major hassle.

37 (edited by garvalf 2016-01-17 22:45:11)

Re: HoustonTracker 2 (TI-82/83/83+/84+)

gotoandplay wrote:

I have tried, but TI Connect does not support TI 82 calculators.

ah, it's true I have a ti83+, not a ti82.

if your pc is powerful enough you can try to use a virtual machine with either windows or linux installed (TiLP is not especially easy to use on linux but I managed to make it work anyway, on windows it worked out of the box for me). Otherwise try from a friend's PC to be sure it's not another problem...

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Yep, I think I am at garvalf's option, after uninstalling everything and doing a prior tilp install, it gives a missing libticables2-5.dll instead of 2-6, haha smile Thanks for the suggestion!

I forgot to mention, the latest tilp install gives an error if you check that you want to download and install the latest gtk runtime during the install - you have to find that gtk install elsewhere for tilp to want to install, too.

I've seen a few youtube vids of people getting tilp to work on linux real easy, I'm guessing the software was native to linux before it was ported to windows.

May take some time to get that setup, but ill let you know once I try that smile I am by no stretch giving up!

Re: HoustonTracker 2 (TI-82/83/83+/84+)

I have to thank Texas Instruments for making me reach new level of rage everytime my calc shut down and clears his memory. AAARGH, the madness.

Anyway, i'll catch this occasion to report a few bugs/ tips.
- don't play to much around when you want to make drone sound with the fx F00. The calc will go nuts and you'll lose your work.
- If you mute a channel using the ,() symbols and load another track without un-muting, the "muting controls" commands in the new track loaded will be inverted. Nothing is damaged, it isn't just how it's supposed to work.
- the "autoinc" option (mode button) is annoying when is automatically inserted when loading the calc. I'd suggest to leave it deactivated when the calc is loaded.


Re: HoustonTracker 2 (TI-82/83/83+/84+)

I'm glad you're still trying to push HT2 to the limits, otherwise these bugs might go undiscovered. And it's probably me who is to blame for the RAM clears yikes Thanks for reporting in any case, I'll look into these. I'll also consider deactivating autoinc by default, since you're not the first to ask wink


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Ok, fixed the mute indicator bug, and AutoInc is now off by default. But the thing I can't figure out is how you manage to crash the calc. I'm on F00, pushing buttons like a maniac, and the damn thing just won't die. How do you do it exactly? Could you by any chance record a video of you crashing the thing?

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Probably it's because i'm using all the save slots. It's the only explanation i can give. Ok, i'll make a video.


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Yeah, a vid would be awesome!

@gotoandplay: I just read somewhere that on newer Windowses, installers that require direct hw access might need to be run via right-click-"run as administrator" even if you are already admin. Dunno if that helps in your case?

Re: HoustonTracker 2 (TI-82/83/83+/84+)

sadly i tried your suggestion and it came up with the familiar missing ticables dll error, and not connecting to the usb device.

I tried a linux VM also - after manually compiling it, the end result was that it didn't flag up an error with the ticables library, but with the ticalcs library instead.

Any workarounds to not using Tilp at all?


Re: HoustonTracker 2 (TI-82/83/83+/84+)

I'm afraid no. Could you post the console output with the ticalcs error? I'll try to pester the TiLP developer if I can't spot anything obvious.

Another option: Try the latest TiLP beta, perhaps there were some relevant bugfixes. See here: https://www.cemetech.net/forum/viewtopi … 917#244917

Re: HoustonTracker 2 (TI-82/83/83+/84+)

That beta version gave a different dll being missing post-installation (libticables2-7.dll rather than 2-6).

Sorry I should have kept the VM at the time for debug purposes when it happened, but a week or so ago I deleted it. I'm not sure I have the stamina for another run of manual compiling and learning what linux is.

I appreciate all the help that you have given, but I think that's it for now. Perhaps in the future I may pay to get it installed by someone more skilled on a computer than I am smile


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Ok, sorry to hear that. Could you let me know which Windows version you're using though? I'm trying to sort things out with the TiLP developer atm.

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Sure it was windows vista (32 bit)


Re: HoustonTracker 2 (TI-82/83/83+/84+)

Thx. Sent you a mail.

Re: HoustonTracker 2 (TI-82/83/83+/84+)

Thank you. I've contacted the tilp developer. He was able to sort out the installation issue.

Now I'm getting a seperate issue with regards to step 7 in your installing ht2 guide for TI-82.

I get as far as receiving crashOS, (well, I think I do). Once I go into transmission mode again to try and send ht2.82p, the calc will say "receiving" and do the little animation on the side, get stuck, and TiLP gives the error "Msg: checksum error. Cause: a transmission error. Try again."

- At this point I have the option to retry skip or cancel. Retrying gives this message from TiLP instead;

"Msg: timeout occured while reading from the device.
Cause: check that link cable is plugged and/or the calculator is ready."

The calc crashes on "Receiving" and you have to remove the batteries to restart it.